summaryrefslogtreecommitdiff
path: root/user/py3-pytest-relaxed/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-pytest-relaxed/APKBUILD')
-rw-r--r--user/py3-pytest-relaxed/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/py3-pytest-relaxed/APKBUILD b/user/py3-pytest-relaxed/APKBUILD
new file mode 100644
index 000000000..9f280b080
--- /dev/null
+++ b/user/py3-pytest-relaxed/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-pytest-relaxed
+_pkgname=pytest-relaxed
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=1.1.5
+pkgrel=0
+pkgdesc="Relaxed test discovery for pytest"
+url="https://pytest-relaxed.readthedocs.io/en/latest/"
+arch="noarch"
+options="!check" # of course a test lib fails its own tests.
+license="BSD-2-Clause"
+depends="python3 py3-pytest py3-six py3-decorator"
+makedepends=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/pytest-relaxed-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH=. pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c4eb981e8969ec9e85c5f390227b5ee2e1c88da6bb331ac4ce7b97b0e0fc435a388f592439281e60d41be9e2858601bee11b527f5c29e496445f7d072e14eaad pytest-relaxed-1.1.5.tar.gz"