summaryrefslogtreecommitdiff
path: root/user/py3-python-dateutil
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-python-dateutil')
-rw-r--r--user/py3-python-dateutil/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/user/py3-python-dateutil/APKBUILD b/user/py3-python-dateutil/APKBUILD
index 56e7075e8..833c61ed2 100644
--- a/user/py3-python-dateutil/APKBUILD
+++ b/user/py3-python-dateutil/APKBUILD
@@ -18,17 +18,17 @@ source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- pytest
+ # Required with PyTest >=4.8, see:
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1734775
+ # https://github.com/pytest-dev/pytest/issues/5678
+ pytest -W ignore::pytest.PytestUnknownMarkWarning
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}