summaryrefslogtreecommitdiff
path: root/user/py3-random2
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-random2')
-rw-r--r--user/py3-random2/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/py3-random2/APKBUILD b/user/py3-random2/APKBUILD
new file mode 100644
index 000000000..631fd4d26
--- /dev/null
+++ b/user/py3-random2/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-random2
+_pkgname=random2
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="A Python module implementing Python 2's RNG"
+url="https://pypi.python.org/pypi/random2"
+arch="noarch"
+license="Python-2.0"
+depends="python3"
+makedepends="py3-setuptools python3-dev"
+install=""
+source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONPATH="build/lib" python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="31de31c27bc6e07e99c24d30e97d9ddc3085fe557bcb0725881d4ab0b4c06e6208f64ba6267098c7b1be4f115ad45b399e841beecc90f71da2fb7d82982e75ff py3-random2-1.0.1.zip"