summaryrefslogtreecommitdiff
path: root/user/py3-setuptools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-setuptools/APKBUILD')
-rw-r--r--user/py3-setuptools/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/user/py3-setuptools/APKBUILD b/user/py3-setuptools/APKBUILD
index ba5e1aebf..6bee60420 100644
--- a/user/py3-setuptools/APKBUILD
+++ b/user/py3-setuptools/APKBUILD
@@ -2,19 +2,18 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-setuptools
_pkgname=setuptools
-pkgver=38.4.0
-pkgrel=1
+pkgver=39.1.0
+pkgrel=0
pkgdesc="A collection of enhancements to the Python distutils"
-url="http://pypi.python.org/pypi/setuptools"
+url="http://pypi.python.org/project/setuptools"
arch="noarch"
license="MIT"
depends="python3"
makedepends="python3-dev"
-#checkdepends="py3-tox"
-options="!check" # Circular dependency with py3-tox. Passes on x86_64
+checkdepends="py3-tox"
+options="net" # Circular dependency with py3-tox. Passes on x86_64
subpackages="py3-easy_install:easy_install"
-# Note: PyPI download is missing tests/requirements.txt
-source="$pkgname-$pkgver.tar.gz::https://github.com/pypa/$_pkgname/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
pythonpath.patch"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -41,5 +40,5 @@ easy_install() {
mv "$pkgdir"/usr/bin/easy_install* "$subpkgdir/usr/bin"
}
-sha512sums="81903ee7ecb19715bbafe7b4e6878d3af5f801a9ff3334e82a599a81a8e6430443c4b765180c53c3c9cdcea338b3fff0bdf26245bc9d2da7d5d41b745de73a24 py3-setuptools-38.4.0.tar.gz
-0c80433534dbb715829f48713690a72a68f6cb7e337215c9aa507df0fbb2a2a242f54d42fab848c6f03729f155dfe0ccb819a6f5d5230e2195e94e20094eec0b pythonpath.patch"
+sha512sums="9fa00930a1923782c2f6356bf992410d42b3dd81b5a673e2957eaf8941787fbea324851c5df48e37601641d004ee900c88a1cfa97ef9df374879586a36efa5c6 py3-setuptools-39.1.0.tar.gz
+ee248df4174240e90a35190e0a47bf0fa4cc5601adc64eff5fd585c8919e47c3a2bb6191b8333800016567d8a0f0f71b7c2306779ea7e4ab7c8951bdee28ef5e pythonpath.patch"