summaryrefslogtreecommitdiff
path: root/user/py3-sphinxcontrib-qthelp
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-sphinxcontrib-qthelp')
-rw-r--r--user/py3-sphinxcontrib-qthelp/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/py3-sphinxcontrib-qthelp/APKBUILD b/user/py3-sphinxcontrib-qthelp/APKBUILD
new file mode 100644
index 000000000..9feee1eae
--- /dev/null
+++ b/user/py3-sphinxcontrib-qthelp/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Brandon Bergren <git@bdragon.rtk0.net>
+# Maintainer: Brandon Bergren <git@bdragon.rtk0.net>
+pkgname=py3-sphinxcontrib-qthelp
+_pkgname=sphinxcontrib-qthelp
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="A Sphinx extension to output QtHelp documents."
+url="https://pypi.python.org/pypi/sphinxcontrib-qthelp"
+arch="noarch"
+options="!check" # Cyclic dependency with sphinx
+license="BSD-2-Clause"
+depends="python3"
+makedepends="python3-dev"
+checkdepends="py3-sphinx py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONWARNINGS="all,ignore::DeprecationWarning:docutils.io" pytest --durations 25
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="8fe840e011fabd596194f539d27a502b77ae8a6030ae1a7646b1af9f203d3578b7420ead655297b2a752f0cb0e6803247c7a79b2ccd2d4662ed9f58398947864 py3-sphinxcontrib-qthelp-1.0.2.tar.gz"