summaryrefslogtreecommitdiff
path: root/user/py3-tox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-tox/APKBUILD')
-rw-r--r--user/py3-tox/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/py3-tox/APKBUILD b/user/py3-tox/APKBUILD
new file mode 100644
index 000000000..9ae7e731a
--- /dev/null
+++ b/user/py3-tox/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-tox
+_pkgname=tox
+pkgver=2.9.1
+pkgrel=0
+pkgdesc="virtualenv management and test command line tool"
+url="https://pypi.python.org/pypi/tox"
+arch="noarch"
+license="MIT"
+depends="py3-py py3-pluggy py3-virtualenv py3-six python3"
+makedepends="python3-dev py3-setuptools"
+#checkdepends="py3-pytest py3-tox"
+options="!check" # Circular dependency with itself and py3-pytest. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ff19b2bb7ac963379f1cccd4973ad9eb4dabfbda976cde7caba50ad010d8fa57c1cba91d63e3e0512e44cc7d350bc9270fbd9b30db1bd55f7d9c239e7623d066 py3-tox-2.9.1.tar.gz"