summaryrefslogtreecommitdiff
path: root/user/py3-typogrify
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-typogrify')
-rw-r--r--user/py3-typogrify/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/py3-typogrify/APKBUILD b/user/py3-typogrify/APKBUILD
new file mode 100644
index 000000000..6d68cbeec
--- /dev/null
+++ b/user/py3-typogrify/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-typogrify
+_pkgname=typogrify
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=2.0.7
+pkgrel=0
+pkgdesc="Python text filters to enhance Web typography"
+url="https://pypi.org/project/typogrify/"
+arch="noarch"
+options="!check" # Test requires Django.
+license="BSD-3-Clause"
+depends="python3 py3-smartypants"
+makedepends=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6212024a88372f1b14e5932c0541ec4d5a2ada7514c1327dc8f3775cd7adf3372cae0037c4310ed4a03fd0657a91eb4c0d114b74172190f7f84d82908441ddd0 typogrify-2.0.7.tar.gz"