summaryrefslogtreecommitdiff
path: root/user/py3-virtualenv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-virtualenv/APKBUILD')
-rw-r--r--user/py3-virtualenv/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/py3-virtualenv/APKBUILD b/user/py3-virtualenv/APKBUILD
new file mode 100644
index 000000000..8a4dde3e1
--- /dev/null
+++ b/user/py3-virtualenv/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-virtualenv
+_pkgname=virtualenv
+pkgver=15.1.0
+pkgrel=0
+pkgdesc="Virtual Python Environment builder"
+url="https://pypi.python.org/pypi/virtualenv"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev"
+checkdepends="py3-pytest py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ test-python3.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+ sed -ie "s/env python$/env python3/" virtualenv.py
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+ cd tests
+ ./test_activate.sh
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d7e95b8c017ec076210f30b6fd4bb44be2f7dc0257492c25bb00fee597d3ade34226d03539180f1edaf2d27b361f8efdabb92d3476e13785b890878ee1295cb2 py3-virtualenv-15.1.0.tar.gz
+8e022416eb10289fd5215f3810203eefb450ce2fca7bdc581b5cd1892f41f34815beec35fc6c744991536c1f2edebd58ab934a4414c6fe2ae6387aea02787ef8 test-python3.patch"