summaryrefslogtreecommitdiff
path: root/user/py3-zope-component/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-zope-component/APKBUILD')
-rw-r--r--user/py3-zope-component/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/py3-zope-component/APKBUILD b/user/py3-zope-component/APKBUILD
new file mode 100644
index 000000000..e915703cf
--- /dev/null
+++ b/user/py3-zope-component/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-zope-component
+_pkgname=zope.component
+pkgver=4.5
+pkgrel=0
+pkgdesc="Zope Component Architecture"
+url="https://pypi.python.org/pypi/zope.component"
+arch="noarch"
+options="!check" # needs nose
+license="ZPL-2.1"
+depends="python3 py3-zope-interface py3-zope-event"
+makedepends="python3-dev"
+subpackages=""
+source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/zope.component/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="cca873bcb62b6eb60825c55fa8fe9704e505c9bec90f851921545d543c23e3995cc9d70ab9e7b8cc6b37853bbcffd09c93891f675ff113e68b56e23d8b28c912 zope.component-4.5.tar.gz"