summaryrefslogtreecommitdiff
path: root/user/py3-zope-hookable/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-zope-hookable/APKBUILD')
-rw-r--r--user/py3-zope-hookable/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/py3-zope-hookable/APKBUILD b/user/py3-zope-hookable/APKBUILD
index 454d1c46e..dcda3dde3 100644
--- a/user/py3-zope-hookable/APKBUILD
+++ b/user/py3-zope-hookable/APKBUILD
@@ -3,25 +3,27 @@
pkgname=py3-zope-hookable
_pkgname=zope.hookable
pkgver=4.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="A library that provides an interface for hookable functions"
url="https://github.com/zopefoundation/zope.hookable"
arch="all"
-options="!check" # needs zope.testing
+# Certified net clean
license="ZPL-2.1"
depends="python3"
-makedepends="python3-dev py3-tox coverage"
+makedepends="python3-dev"
subpackages=""
source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}