summaryrefslogtreecommitdiff
path: root/user/qemu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/qemu/APKBUILD')
-rw-r--r--user/qemu/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/user/qemu/APKBUILD b/user/qemu/APKBUILD
index f64964b3c..9d7239c45 100644
--- a/user/qemu/APKBUILD
+++ b/user/qemu/APKBUILD
@@ -5,7 +5,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qemu
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Machine emulator and virtualisation software"
url="https://www.qemu.org/"
arch="all"
@@ -34,7 +34,6 @@ makedepends="
linux-headers
lzo-dev
ncurses-dev
- paxmark
python3
snappy-dev
spice-dev
@@ -56,6 +55,7 @@ subpackages="$pkgname-doc $pkgname-lang $pkgname-guest-agent:guest
_user_subsystems="
aarch64
+ aarch64_be
alpha
arm
armeb
@@ -71,11 +71,14 @@ _user_subsystems="
mipsel
mipsn32
mipsn32el
+ nios2
or1k
ppc
ppc64
ppc64abi32
ppc64le
+ riscv32
+ riscv64
s390x
sh4
sh4eb
@@ -83,7 +86,9 @@ _user_subsystems="
sparc32plus
sparc64
tilegx
- x86_64"
+ x86_64
+ xtensa
+ xtensaeb"
_system_subsystems="
system-aarch64
system-alpha
@@ -209,6 +214,7 @@ _compile_common() {
--disable-werror \
--disable-sdl \
--disable-xen \
+ --disable-gcrypt \
--cc="${CC:-gcc}" \
--python="/usr/bin/python3" \
"$@"
@@ -285,7 +291,6 @@ package() {
cd "$builddir"/build
make DESTDIR="$pkgdir" install
- paxmark -m "$pkgdir"/usr/bin/qemu-system-*
install -Dm640 -g qemu "$srcdir"/bridge.conf \
"$pkgdir"/etc/qemu/bridge.conf