summaryrefslogtreecommitdiff
path: root/user/qt5-qtdeclarative
diff options
context:
space:
mode:
Diffstat (limited to 'user/qt5-qtdeclarative')
-rw-r--r--user/qt5-qtdeclarative/APKBUILD10
-rw-r--r--user/qt5-qtdeclarative/disable-jit-pmmx.patch17
-rw-r--r--user/qt5-qtdeclarative/endian.patch31
3 files changed, 54 insertions, 4 deletions
diff --git a/user/qt5-qtdeclarative/APKBUILD b/user/qt5-qtdeclarative/APKBUILD
index 349bdfd84..27f526671 100644
--- a/user/qt5-qtdeclarative/APKBUILD
+++ b/user/qt5-qtdeclarative/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qt5-qtdeclarative
_pkgname=${pkgname#qt5-}-everywhere-src
-pkgver=5.12.6
-pkgrel=0
+pkgver=5.12.9
+pkgrel=1
pkgdesc="Qt Declarative and Qt Quick 2"
url="https://www.qt.io/"
arch="all"
@@ -13,6 +13,7 @@ subpackages="$pkgname-dev"
source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
add-execinfo.patch
disable-jit-pmmx.patch
+ endian.patch
python3.patch
"
@@ -36,7 +37,8 @@ package() {
done
}
-sha512sums="b60537dd10bc2c91c7a40035248d898733fbf1486ae2e00f8d8de37af965dcb1ee48828f82704441370656f0821896b09acf7f06dd0a7c398a2a9497ce4f0250 qtdeclarative-everywhere-src-5.12.6.tar.xz
+sha512sums="5357cdc56c0835c3c5d397839faf07ac61af4ed3067765edd32122aecd204849ce4b9a3b1eb5e631efdf832994c682851f43025796fb1bd56b32061a1c048bc8 qtdeclarative-everywhere-src-5.12.9.tar.xz
065ab2440fd0a81e76fe8873b0991929fad3d4189c8938e0205e94478a6cdce81ef710e3bad19cd5ca0b5ea0f8b3cd1b366969ddede51070496d1d02ace59220 add-execinfo.patch
-d21aeba1167ebebcdfc54eca14f714efc3de7252513ea4fd096dcbcab2d509faa06d94a6b8978ee7ea15b1c9acb94bc23662debecc2f443a4a5258b90c872048 disable-jit-pmmx.patch
+d21720d9d26fa323e769f5edb97f17b189e07d98ea825aad7d4d39dabd7293e49ce6a2d79a7997f4f0c825d3ac84ac148c68261d1f24629f5f4026a5cd733076 disable-jit-pmmx.patch
+4830800e2440e7a69073115e0e0d3ed42bcc99bdf04d4ea662508ff44edf30346211988171972bb49676c2b6aaa4cef684e9ab97e97091b656d517bbb790a584 endian.patch
bb39564f2d68e5635141f3de950ff7ec8174d2c972d066049153039268154de1cad7fcb82d191e325db0a0317ed90eb869431432e32494fa52584af1536f1990 python3.patch"
diff --git a/user/qt5-qtdeclarative/disable-jit-pmmx.patch b/user/qt5-qtdeclarative/disable-jit-pmmx.patch
index 971fd9f14..a13522a89 100644
--- a/user/qt5-qtdeclarative/disable-jit-pmmx.patch
+++ b/user/qt5-qtdeclarative/disable-jit-pmmx.patch
@@ -16,3 +16,20 @@ So we remove the JIT entirely on pmmx/x86.
&& (defined(Q_OS_WIN) || defined(Q_OS_LINUX) || defined(Q_OS_QNX) || defined(Q_OS_MAC) || defined(Q_OS_FREEBSD))
# define V4_ENABLE_JIT
#elif defined(Q_PROCESSOR_ARM_32) && (QT_POINTER_SIZE == 4) \
+--- qtdeclarative-everywhere-src-5.12.6/src/qml/qml/v8/qv8engine.cpp.old 2019-11-07 11:01:48.000000000 +0000
++++ qtdeclarative-everywhere-src-5.12.6/src/qml/qml/v8/qv8engine.cpp 2020-08-09 17:28:54.028331206 +0000
+@@ -138,14 +138,6 @@
+ , m_xmlHttpRequestData(nullptr)
+ #endif
+ {
+-#ifndef Q_OS_WASM // wasm does not have working simd QTBUG-63924
+-#ifdef Q_PROCESSOR_X86_32
+- if (!qCpuHasFeature(SSE2)) {
+- qFatal("This program requires an X86 processor that supports SSE2 extension, at least a Pentium 4 or newer");
+- }
+-#endif
+-#endif
+-
+ QML_MEMORY_SCOPE_STRING("QV8Engine::QV8Engine");
+ qMetaTypeId<QJSValue>();
+ qMetaTypeId<QList<int> >();
diff --git a/user/qt5-qtdeclarative/endian.patch b/user/qt5-qtdeclarative/endian.patch
new file mode 100644
index 000000000..313e9ca5c
--- /dev/null
+++ b/user/qt5-qtdeclarative/endian.patch
@@ -0,0 +1,31 @@
+From 15b3a8fc8635e04fa7ea1275b910772d8f2820a2 Mon Sep 17 00:00:00 2001
+From: q66 <daniel@octaforge.org>
+Date: Sun, 10 May 2020 02:44:47 +0200
+Subject: [PATCH] always default to qtquick software backend on big endian
+
+the default backend is buggy and breaks rendering of various
+components of KDE Plasma and LXQt, so just default to software
+so the user doesn't have to specify QT_QUICK_BACKEND
+---
+ qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp
+index 66add51..a0fdaa2 100644
+--- qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp
++++ qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp
+@@ -139,7 +139,10 @@ QSGAdaptationBackendData *contextFactory()
+ // If this platform does not support OpenGL, and no backend has been set
+ // default to the software renderer
+ if (requestedBackend.isEmpty()
+- && !QGuiApplicationPrivate::platformIntegration()->hasCapability(QPlatformIntegration::OpenGL)) {
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
++ && !QGuiApplicationPrivate::platformIntegration()->hasCapability(QPlatformIntegration::OpenGL)
++#endif
++ ) {
+ requestedBackend = QString::fromLocal8Bit("software");
+ }
+
+--
+2.25.1
+