summaryrefslogtreecommitdiff
path: root/user/qt5-qtgraphicaleffects/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/qt5-qtgraphicaleffects/APKBUILD')
-rw-r--r--user/qt5-qtgraphicaleffects/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/qt5-qtgraphicaleffects/APKBUILD b/user/qt5-qtgraphicaleffects/APKBUILD
new file mode 100644
index 000000000..00f5021dc
--- /dev/null
+++ b/user/qt5-qtgraphicaleffects/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtgraphicaleffects
+_pkgname=qtgraphicaleffects-opensource-src
+pkgver=5.9.6
+pkgrel=0
+pkgdesc="Qt 5 - Pre-made visual effects for QML"
+url="https://qt.io/"
+arch="all"
+license="LGPL-2.0 with exceptions OR GPL-3.0 with exceptions"
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
+
+_qt5_prefix=/usr/lib/qt5
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="a319dd594bd9048242512cefddf8db0474677d48a03c7616633d7e3b7dd6637ff2c7cce206d25d3938a6b3f3cc7ffc037630e5923caea0bfa7612e99522e36ea qtgraphicaleffects-opensource-src-5.9.6.tar.xz"