summaryrefslogtreecommitdiff
path: root/user/qt5-qtimageformats/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/qt5-qtimageformats/APKBUILD')
-rw-r--r--user/qt5-qtimageformats/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/user/qt5-qtimageformats/APKBUILD b/user/qt5-qtimageformats/APKBUILD
new file mode 100644
index 000000000..92ab99eb8
--- /dev/null
+++ b/user/qt5-qtimageformats/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtimageformats
+_pkgname=qtimageformats-everywhere-src
+pkgver=5.12.6
+pkgrel=0
+pkgdesc="Image handling plugin for Qt"
+url="https://www.qt.io/"
+arch="all"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends=""
+makedepends="jasper-dev libwebp-dev qt5-qtbase-dev tiff-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
+
+_qt5_prefix=/usr/lib/qt5
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ qmake
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="0f8c481f647d6047b66564247b604a741f16c2758e96245abd0ef190ba50c937b6c713c7a466b911dd8e074174a7b30e6ad1ed0cd7ed915c4cda9dc4dccd8ab9 qtimageformats-everywhere-src-5.12.6.tar.xz"