summaryrefslogtreecommitdiff
path: root/user/qt5-qtquickcontrols/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/qt5-qtquickcontrols/APKBUILD')
-rw-r--r--user/qt5-qtquickcontrols/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/user/qt5-qtquickcontrols/APKBUILD b/user/qt5-qtquickcontrols/APKBUILD
index 7666875ce..9468c6bf8 100644
--- a/user/qt5-qtquickcontrols/APKBUILD
+++ b/user/qt5-qtquickcontrols/APKBUILD
@@ -1,30 +1,28 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qt5-qtquickcontrols
-_pkgname=qtquickcontrols-opensource-src
-pkgver=5.9.7
+_pkgname=qtquickcontrols-everywhere-src
+pkgver=5.12.6
pkgrel=0
-pkgdesc="Qt 5 - controls for use with Qt Quick"
+pkgdesc="Controls for use with Qt Quick"
url="https://www.qt.io/"
arch="all"
-license="(LGPL-2.0 with exceptions OR GPL-3.0 with exceptions) AND GFDL-1.3"
+license="(LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0) AND GFDL-1.3"
+depends=""
makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
qmake
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install INSTALL_ROOT="$pkgdir"
}
-sha512sums="87b8af09035f77bf02e6995a173d381536c50896604dcd884f7adede4d70464d5ee28161fda7b449ad851a728254cee00b7984099c4c9f024623a16157c0a656 qtquickcontrols-opensource-src-5.9.7.tar.xz"
+sha512sums="901bcf7c800406f2749ebc251a7b0419fdbab4599881475aae7f74ce4eac5347837f5e667f78774ad914a1c3fbf42e144606c9592bff3f34e899870709fb4c87 qtquickcontrols-everywhere-src-5.12.6.tar.xz"