summaryrefslogtreecommitdiff
path: root/user/qt5-qtserialport/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/qt5-qtserialport/APKBUILD')
-rw-r--r--user/qt5-qtserialport/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/qt5-qtserialport/APKBUILD b/user/qt5-qtserialport/APKBUILD
new file mode 100644
index 000000000..78ce5b969
--- /dev/null
+++ b/user/qt5-qtserialport/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtserialport
+_pkgname=qtserialport-opensource-src
+pkgver=5.9.6
+pkgrel=0
+pkgdesc="Qt 5 - Connect Qt applications to serial ports"
+url="https://www.qt.io/"
+arch="all"
+options="!check"
+license="LGPLv2 with exceptions OR GPLv3 with exceptions"
+depends=""
+makedepends="eudev-dev qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="a4f5230c78772aa8899471dea90bab38a1cc021c22737f959e1a6852d18e7faeaadba4d329e49b3c9a3b7ef5fea69febb550e7fb4a9d99902d0e80a144822847 qtserialport-opensource-src-5.9.6.tar.xz"