summaryrefslogtreecommitdiff
path: root/user/qt5-qtwebkit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/qt5-qtwebkit/APKBUILD')
-rw-r--r--user/qt5-qtwebkit/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/user/qt5-qtwebkit/APKBUILD b/user/qt5-qtwebkit/APKBUILD
index b2a408ddb..37eb11b1c 100644
--- a/user/qt5-qtwebkit/APKBUILD
+++ b/user/qt5-qtwebkit/APKBUILD
@@ -38,9 +38,13 @@ build() {
local _maybe_smaller=""
cd "$builddir"
+ # On 32-bit x86, ld.bfd will run out of memory if debugging information
+ # is built. See https://sourceware.org/bugzilla/show_bug.cgi?id=23470
+ # for more information.
case "$CARCH" in
pmmx) _maybe_smaller="QMAKE_CXXFLAGS_DEBUG+=-g0"
esac
+
qmake $_maybe_smaller
# /usr/include/fortify/stdlib.h:20:25: fatal error: stdlib.h: No such file or directory