summaryrefslogtreecommitdiff
path: root/user/qt5-qtwebsockets/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/qt5-qtwebsockets/APKBUILD')
-rw-r--r--user/qt5-qtwebsockets/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/qt5-qtwebsockets/APKBUILD b/user/qt5-qtwebsockets/APKBUILD
new file mode 100644
index 000000000..2d7914eb3
--- /dev/null
+++ b/user/qt5-qtwebsockets/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtwebsockets
+_pkgname=qtwebsockets-opensource-src
+pkgver=5.9.6
+pkgrel=0
+pkgdesc="Qt 5 - Pure Qt implementation of WebSockets"
+url="https://www.qt.io/"
+arch="all"
+options="!check"
+license="LGPLv2 with exceptions OR GPLv3 with exceptions"
+depends=""
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="3ecb44b6046d1a57ee85d261107b332f219aaed312712f817127cf0715f22ef3688192bccd86bc2057f79b9b1d69bfbceb3b8cac97ddaa33afc4bb3284b857dd qtwebsockets-opensource-src-5.9.6.tar.xz"