summaryrefslogtreecommitdiff
path: root/user/rpm/musl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/rpm/musl.patch')
-rw-r--r--user/rpm/musl.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/rpm/musl.patch b/user/rpm/musl.patch
new file mode 100644
index 000000000..65f3a10aa
--- /dev/null
+++ b/user/rpm/musl.patch
@@ -0,0 +1,33 @@
+Upstream: No
+Reason: Fixes compilation with musl
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -229,6 +229,7 @@ AC_SEARCH_LIBS(dlopen, [dl])
+ # Check for libelf library. Prefer external, otherwise none.
+ WITH_LIBELF_LIB=
+ AC_CHECK_HEADER([libelf.h])
++AC_CHECK_HEADERS([error.h], [WITH_ERROR_H=yes])
+ AC_CHECK_HEADERS([gelf.h], [
+ AC_CHECK_LIB(elf, gelf_getvernaux, [
+ AC_DEFINE(HAVE_LIBELF, 1, [Define to 1 if you have the 'elf' library (-lelf).])
+@@ -237,7 +238,7 @@ AC_CHECK_HEADERS([gelf.h], [
+ ])
+ ])
+ AC_SUBST(WITH_LIBELF_LIB)
+-AM_CONDITIONAL(LIBELF,[test "$WITH_LIBELF" = yes])
++AM_CONDITIONAL(LIBELF,[test "$WITH_LIBELF" = yes && test "$WITH_ERROR_H" = yes])
+
+ AC_CHECK_HEADERS([dwarf.h], [
+ WITH_LIBDWARF=yes
+--- a/rpmio/digest_nss.c
++++ b/rpmio/digest_nss.c
+@@ -6,6 +6,7 @@
+ #include <keyhi.h>
+ #include <cryptohi.h>
+ #include <blapit.h>
++#include <signal.h>
+
+ #include <rpm/rpmlog.h>
+ #include "rpmio/digest.h"
+