summaryrefslogtreecommitdiff
path: root/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch')
-rw-r--r--user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch74
1 files changed, 38 insertions, 36 deletions
diff --git a/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch b/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
index 2df7a6654..27556e720 100644
--- a/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
+++ b/user/rust/0005-Remove-nostdlib-and-musl_root-from-musl-targets.patch
@@ -1,7 +1,7 @@
-From e8ef432c23ea9fb70b28bea07042b33f1050569b Mon Sep 17 00:00:00 2001
+From 87b08278a8640db921cbd699c7a7dc7e1864f21e Mon Sep 17 00:00:00 2001
From: Samuel Holland <samuel@sholland.org>
Date: Fri, 8 Sep 2017 22:11:14 -0500
-Subject: [PATCH 05/16] Remove -nostdlib and musl_root from musl targets
+Subject: [PATCH 05/18] Remove -nostdlib and musl_root from musl targets
---
config.toml.example | 6 ----
@@ -9,7 +9,7 @@ Subject: [PATCH 05/16] Remove -nostdlib and musl_root from musl targets
src/bootstrap/cc_detect.rs | 27 ++----------------
src/bootstrap/compile.rs | 21 +-------------
src/bootstrap/config.rs | 7 -----
- src/bootstrap/configure.py | 22 ---------------
+ src/bootstrap/configure.py | 24 ----------------
src/bootstrap/lib.rs | 8 ------
src/bootstrap/sanity.rs | 28 -------------------
.../dist-i586-gnu-i586-i686-musl/Dockerfile | 2 --
@@ -17,13 +17,13 @@ Subject: [PATCH 05/16] Remove -nostdlib and musl_root from musl targets
src/ci/docker/dist-x86_64-musl/Dockerfile | 1 -
src/ci/docker/test-various/Dockerfile | 1 -
src/librustc_target/spec/linux_musl_base.rs | 16 -----------
- 13 files changed, 4 insertions(+), 152 deletions(-)
+ 13 files changed, 4 insertions(+), 154 deletions(-)
diff --git a/config.toml.example b/config.toml.example
-index c14adf8ce33..8ec8d2bbbb7 100644
+index cb9f388a8e4..c7d669c91b8 100644
--- a/config.toml.example
+++ b/config.toml.example
-@@ -479,12 +479,6 @@
+@@ -474,12 +474,6 @@
# only use static libraries. If unset, the target's default linkage is used.
#crt-static = false
@@ -37,10 +37,10 @@ index c14adf8ce33..8ec8d2bbbb7 100644
#wasi-root = "..."
diff --git a/src/bootstrap/bin/rustc.rs b/src/bootstrap/bin/rustc.rs
-index 595deb07ec8..c077dc1581e 100644
+index 54b689fb062..81e7e46df37 100644
--- a/src/bootstrap/bin/rustc.rs
+++ b/src/bootstrap/bin/rustc.rs
-@@ -145,16 +145,6 @@ fn main() {
+@@ -164,16 +164,6 @@ fn main() {
cmd.arg("-Cprefer-dynamic");
}
@@ -58,10 +58,10 @@ index 595deb07ec8..c077dc1581e 100644
let mut root = OsString::from("native=");
root.push(&s);
diff --git a/src/bootstrap/cc_detect.rs b/src/bootstrap/cc_detect.rs
-index 400375cd201..0394ab7a8a7 100644
+index c58a98bac36..3103b29a5b9 100644
--- a/src/bootstrap/cc_detect.rs
+++ b/src/bootstrap/cc_detect.rs
-@@ -84,7 +84,7 @@ pub fn find(build: &mut Build) {
+@@ -86,7 +86,7 @@ pub fn find(build: &mut Build) {
if let Some(cc) = config.and_then(|c| c.cc.as_ref()) {
cfg.compiler(cc);
} else {
@@ -70,7 +70,7 @@ index 400375cd201..0394ab7a8a7 100644
}
let compiler = cfg.get_compiler();
-@@ -107,7 +107,7 @@ pub fn find(build: &mut Build) {
+@@ -109,7 +109,7 @@ pub fn find(build: &mut Build) {
cfg.compiler(cxx);
true
} else if build.hosts.contains(&target) || build.build == target {
@@ -79,7 +79,7 @@ index 400375cd201..0394ab7a8a7 100644
true
} else {
false
-@@ -134,8 +134,7 @@ pub fn find(build: &mut Build) {
+@@ -136,8 +136,7 @@ pub fn find(build: &mut Build) {
fn set_compiler(cfg: &mut cc::Build,
compiler: Language,
target: Interned<String>,
@@ -89,7 +89,7 @@ index 400375cd201..0394ab7a8a7 100644
match &*target {
// When compiling for android we may have the NDK configured in the
// config.toml in which case we look there. Otherwise the default
-@@ -175,26 +174,6 @@ fn set_compiler(cfg: &mut cc::Build,
+@@ -177,26 +176,6 @@ fn set_compiler(cfg: &mut cc::Build,
}
}
@@ -117,10 +117,10 @@ index 400375cd201..0394ab7a8a7 100644
}
}
diff --git a/src/bootstrap/compile.rs b/src/bootstrap/compile.rs
-index 576267e6948..8e5de3907f6 100644
+index 4cd793adaf5..4839ec9badd 100644
--- a/src/bootstrap/compile.rs
+++ b/src/bootstrap/compile.rs
-@@ -116,20 +116,7 @@ impl Step for Std {
+@@ -115,20 +115,7 @@ impl Step for Std {
fn copy_third_party_objects(builder: &Builder<'_>, compiler: &Compiler, target: Interned<String>) {
let libdir = builder.sysroot_libdir(*compiler, target);
@@ -142,7 +142,7 @@ index 576267e6948..8e5de3907f6 100644
for &obj in &["crt1.o"] {
builder.copy(
&builder.wasi_root(target).unwrap().join("lib/wasm32-wasi").join(obj),
-@@ -219,12 +206,6 @@ pub fn std_cargo(builder: &Builder<'_>,
+@@ -218,12 +205,6 @@ pub fn std_cargo(builder: &Builder<'_>,
.arg("--manifest-path")
.arg(builder.src.join("src/libstd/Cargo.toml"));
@@ -156,10 +156,10 @@ index 576267e6948..8e5de3907f6 100644
if let Some(p) = builder.wasi_root(target) {
cargo.env("WASI_ROOT", p);
diff --git a/src/bootstrap/config.rs b/src/bootstrap/config.rs
-index 66f504ea924..5bb211501b1 100644
+index a5bfafdfdb4..cc0b489870b 100644
--- a/src/bootstrap/config.rs
+++ b/src/bootstrap/config.rs
-@@ -133,8 +133,6 @@ pub struct Config {
+@@ -132,8 +132,6 @@ pub struct Config {
pub print_step_timings: bool,
pub missing_tools: bool,
@@ -168,7 +168,7 @@ index 66f504ea924..5bb211501b1 100644
pub prefix: Option<PathBuf>,
pub sysconfdir: Option<PathBuf>,
pub datadir: Option<PathBuf>,
-@@ -169,7 +167,6 @@ pub struct Target {
+@@ -168,7 +166,6 @@ pub struct Target {
pub linker: Option<PathBuf>,
pub ndk: Option<PathBuf>,
pub crt_static: Option<bool>,
@@ -176,7 +176,7 @@ index 66f504ea924..5bb211501b1 100644
pub wasi_root: Option<PathBuf>,
pub qemu_rootfs: Option<PathBuf>,
pub no_std: bool,
-@@ -307,7 +304,6 @@ struct Rust {
+@@ -306,7 +303,6 @@ struct Rust {
backtrace: Option<bool>,
default_linker: Option<String>,
channel: Option<String>,
@@ -184,7 +184,7 @@ index 66f504ea924..5bb211501b1 100644
rpath: Option<bool>,
optimize_tests: Option<bool>,
codegen_tests: Option<bool>,
-@@ -346,7 +342,6 @@ struct TomlTarget {
+@@ -344,7 +340,6 @@ struct TomlTarget {
linker: Option<String>,
android_ndk: Option<String>,
crt_static: Option<bool>,
@@ -192,15 +192,15 @@ index 66f504ea924..5bb211501b1 100644
wasi_root: Option<String>,
qemu_rootfs: Option<String>,
}
-@@ -569,7 +564,6 @@ impl Config {
+@@ -564,7 +559,6 @@ impl Config {
set(&mut config.llvm_tools_enabled, rust.llvm_tools);
config.rustc_parallel = rust.parallel_compiler.unwrap_or(false);
config.rustc_default_linker = rust.default_linker.clone();
- config.musl_root = rust.musl_root.clone().map(PathBuf::from);
config.save_toolstates = rust.save_toolstates.clone().map(PathBuf::from);
- set(&mut config.deny_warnings, rust.deny_warnings.or(flags.warnings));
+ set(&mut config.deny_warnings, flags.deny_warnings.or(rust.deny_warnings));
set(&mut config.backtrace_on_ice, rust.backtrace_on_ice);
-@@ -607,7 +601,6 @@ impl Config {
+@@ -602,7 +596,6 @@ impl Config {
target.ranlib = cfg.ranlib.clone().map(PathBuf::from);
target.linker = cfg.linker.clone().map(PathBuf::from);
target.crt_static = cfg.crt_static.clone();
@@ -209,10 +209,10 @@ index 66f504ea924..5bb211501b1 100644
target.qemu_rootfs = cfg.qemu_rootfs.clone().map(PathBuf::from);
diff --git a/src/bootstrap/configure.py b/src/bootstrap/configure.py
-index 907983d43ad..e91f6fcbe4b 100755
+index 346f0cb2039..80409781ede 100755
--- a/src/bootstrap/configure.py
+++ b/src/bootstrap/configure.py
-@@ -111,28 +111,6 @@ v("aarch64-linux-android-ndk", "target.aarch64-linux-android.android-ndk",
+@@ -110,30 +110,6 @@ v("aarch64-linux-android-ndk", "target.aarch64-linux-android.android-ndk",
"aarch64-linux-android NDK standalone path")
v("x86_64-linux-android-ndk", "target.x86_64-linux-android.android-ndk",
"x86_64-linux-android NDK standalone path")
@@ -230,7 +230,9 @@ index 907983d43ad..e91f6fcbe4b 100755
- "arm-unknown-linux-musleabihf install directory")
-v("musl-root-armv5te", "target.armv5te-unknown-linux-musleabi.musl-root",
- "armv5te-unknown-linux-musleabi install directory")
--v("musl-root-armv7", "target.armv7-unknown-linux-musleabihf.musl-root",
+-v("musl-root-armv7", "target.armv7-unknown-linux-musleabi.musl-root",
+- "armv7-unknown-linux-musleabi install directory")
+-v("musl-root-armv7hf", "target.armv7-unknown-linux-musleabihf.musl-root",
- "armv7-unknown-linux-musleabihf install directory")
-v("musl-root-aarch64", "target.aarch64-unknown-linux-musl.musl-root",
- "aarch64-unknown-linux-musl install directory")
@@ -242,10 +244,10 @@ index 907983d43ad..e91f6fcbe4b 100755
"rootfs in qemu testing, you probably don't want to use this")
v("qemu-aarch64-rootfs", "target.aarch64-unknown-linux-gnu.qemu-rootfs",
diff --git a/src/bootstrap/lib.rs b/src/bootstrap/lib.rs
-index 867df81d972..4fb57aa6db6 100644
+index 3374c88550a..76cc0dd28a5 100644
--- a/src/bootstrap/lib.rs
+++ b/src/bootstrap/lib.rs
-@@ -847,14 +847,6 @@ impl Build {
+@@ -846,14 +846,6 @@ impl Build {
}
}
@@ -261,10 +263,10 @@ index 867df81d972..4fb57aa6db6 100644
fn wasi_root(&self, target: Interned<String>) -> Option<&Path> {
self.config.target_config.get(&target)
diff --git a/src/bootstrap/sanity.rs b/src/bootstrap/sanity.rs
-index dc65fb9b797..060ba6d9e42 100644
+index 4e3930c8da7..3b109548056 100644
--- a/src/bootstrap/sanity.rs
+++ b/src/bootstrap/sanity.rs
-@@ -176,34 +176,6 @@ pub fn check(build: &mut Build) {
+@@ -187,34 +187,6 @@ pub fn check(build: &mut Build) {
}
}
@@ -313,17 +315,17 @@ index ba2d32a9296..412c37fdd12 100644
--disable-docs
diff --git a/src/ci/docker/dist-various-1/Dockerfile b/src/ci/docker/dist-various-1/Dockerfile
-index 5ab4be328a9..f3b622e6037 100644
+index ae2ea8ef95a..19426156d1f 100644
--- a/src/ci/docker/dist-various-1/Dockerfile
+++ b/src/ci/docker/dist-various-1/Dockerfile
-@@ -131,13 +131,6 @@ ENV CC_mipsel_unknown_linux_musl=mipsel-openwrt-linux-gcc \
+@@ -134,13 +134,6 @@ ENV CC_mipsel_unknown_linux_musl=mipsel-openwrt-linux-gcc \
CXX_thumbv7neon_unknown_linux_gnueabihf=arm-linux-gnueabihf-g++
ENV RUST_CONFIGURE_ARGS \
- --musl-root-armv5te=/musl-armv5te \
- --musl-root-arm=/musl-arm \
- --musl-root-armhf=/musl-armhf \
-- --musl-root-armv7=/musl-armv7 \
+- --musl-root-armv7hf=/musl-armv7hf \
- --musl-root-aarch64=/musl-aarch64 \
- --musl-root-mips=/musl-mips \
- --musl-root-mipsel=/musl-mipsel \
@@ -343,10 +345,10 @@ index 385eefde846..81d4f7737e8 100644
--disable-docs \
--set target.x86_64-unknown-linux-musl.crt-static=false \
diff --git a/src/ci/docker/test-various/Dockerfile b/src/ci/docker/test-various/Dockerfile
-index c45b1a9a0f1..440796ff3ec 100644
+index 6a2600d8756..53a99ae1353 100644
--- a/src/ci/docker/test-various/Dockerfile
+++ b/src/ci/docker/test-various/Dockerfile
-@@ -27,7 +27,6 @@ COPY scripts/sccache.sh /scripts/
+@@ -29,7 +29,6 @@ COPY scripts/sccache.sh /scripts/
RUN sh /scripts/sccache.sh
ENV RUST_CONFIGURE_ARGS \