summaryrefslogtreecommitdiff
path: root/user/rust/0011-Ignore-broken-and-non-applicable-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/rust/0011-Ignore-broken-and-non-applicable-tests.patch')
-rw-r--r--user/rust/0011-Ignore-broken-and-non-applicable-tests.patch62
1 files changed, 0 insertions, 62 deletions
diff --git a/user/rust/0011-Ignore-broken-and-non-applicable-tests.patch b/user/rust/0011-Ignore-broken-and-non-applicable-tests.patch
deleted file mode 100644
index ebf711f77..000000000
--- a/user/rust/0011-Ignore-broken-and-non-applicable-tests.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 63a413a24f98461476aac7ac7ead69c948874e7d Mon Sep 17 00:00:00 2001
-From: Samuel Holland <samuel@sholland.org>
-Date: Sun, 16 Sep 2018 16:38:48 +0000
-Subject: [PATCH 11/14] Ignore broken and non-applicable tests
-
-long-linker-command-lines: takes >10 minutes to run (but still passes)
-sparc-struct-abi: no sparc target
-sysroot-crates-are-unstable: can't run rustc without rpath
----
- src/test/codegen/sparc-struct-abi.rs | 1 +
- src/test/run-make-fulldeps/long-linker-command-lines/Makefile | 1 -
- src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile | 2 +-
- src/test/run-pass/simd/simd-intrinsic-generic-select.rs | 2 ++
- 4 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/test/codegen/sparc-struct-abi.rs b/src/test/codegen/sparc-struct-abi.rs
-index 78e5b14a21..6f93e93286 100644
---- a/src/test/codegen/sparc-struct-abi.rs
-+++ b/src/test/codegen/sparc-struct-abi.rs
-@@ -4,6 +4,7 @@
-
- // only-sparc64
- // compile-flags: -O --target=sparc64-unknown-linux-gnu --crate-type=rlib
-+// ignore-test
- #![feature(no_core, lang_items)]
- #![no_core]
-
-diff --git a/src/test/run-make-fulldeps/long-linker-command-lines/Makefile b/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
-index 5876fbc94b..e9f5c33b77 100644
---- a/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
-+++ b/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
-@@ -2,4 +2,3 @@
-
- all:
- $(RUSTC) foo.rs -g -O
-- RUSTC="$(RUSTC_ORIGINAL)" $(call RUN,foo)
-diff --git a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
-index 9e77070685..7784230b46 100644
---- a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
-+++ b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
-@@ -1,4 +1,4 @@
- -include ../tools.mk
-
- all:
-- env '$(HOST_RPATH_ENV)' python2.7 test.py
-+ true
-diff --git a/src/test/run-pass/simd/simd-intrinsic-generic-select.rs b/src/test/run-pass/simd/simd-intrinsic-generic-select.rs
-index f79b140494..39080c8c90 100644
---- a/src/test/run-pass/simd/simd-intrinsic-generic-select.rs
-+++ b/src/test/run-pass/simd/simd-intrinsic-generic-select.rs
-@@ -2,6 +2,8 @@
- #![allow(non_camel_case_types)]
-
- // ignore-emscripten
-+// ignore-powerpc
-+// ignore-powerpc64
-
- // Test that the simd_select intrinsics produces correct results.
-
---
-2.21.0
-