summaryrefslogtreecommitdiff
path: root/user/samurai/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/samurai/APKBUILD')
-rw-r--r--user/samurai/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/samurai/APKBUILD b/user/samurai/APKBUILD
new file mode 100644
index 000000000..e63de08c9
--- /dev/null
+++ b/user/samurai/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+pkgname=samurai
+pkgver=1.0
+pkgrel=0
+pkgdesc="Pure-C drop-in replacement for ninja"
+url="https://github.com/michaelforney/samurai"
+arch="all"
+options="!check" # no test suite and upstream build-tests against Chromium anyhow
+license="Apache-2.0 OR ISC"
+depends=""
+makedepends=""
+provides="ninja"
+replaces="ninja"
+subpackages="$pkgname-doc"
+source="https://github.com/michaelforney/samurai/releases/download/$pkgver/samurai-$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ cd "$pkgdir/usr/bin"
+ ln -s samu ninja
+}
+
+sha512sums="87b2a11a39dc36f3582abdc7c9d358c8fce241fe4155b5177d3e8588d1c040a62eb9daafd2365febbfadd6fcc27a3ceacf6f29ca6f871c822aad6f4bad527a51 samurai-1.0.tar.gz"