summaryrefslogtreecommitdiff
path: root/user/scummvm
diff options
context:
space:
mode:
Diffstat (limited to 'user/scummvm')
-rw-r--r--user/scummvm/APKBUILD11
-rw-r--r--user/scummvm/fluidsynth.patch37
2 files changed, 43 insertions, 5 deletions
diff --git a/user/scummvm/APKBUILD b/user/scummvm/APKBUILD
index 8c4ae8f36..d6e001f70 100644
--- a/user/scummvm/APKBUILD
+++ b/user/scummvm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Tambra Wilcox <Tambra@J30AD.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=scummvm
-pkgver=2.0.0
+pkgver=2.1.1
pkgrel=0
pkgdesc="Allows running classic point-and-click adventure games"
url="https://www.scummvm.org/"
@@ -13,10 +13,11 @@ makedepends="alsa-lib-dev curl-dev flac-dev fluidsynth-dev freetype-dev
libjpeg-turbo-dev libmpeg2-dev libogg-dev libpng-dev libvorbis-dev
sdl-dev zlib-dev"
subpackages="$pkgname-doc"
-source="https://www.scummvm.org/frs/scummvm/$pkgver/scummvm-$pkgver.tar.bz2"
+source="https://www.scummvm.org/frs/scummvm/$pkgver/scummvm-$pkgver.tar.bz2
+ fluidsynth.patch
+ "
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--disable-readline
@@ -24,8 +25,8 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="66c689d776b8098d752ef696232f80f175f3bff9f523e6dceb246849e785889d135452f48eafa5f2664047297de8592c862677270de4bf83731f10e178ad6847 scummvm-2.0.0.tar.bz2"
+sha512sums="c27de3cf226ca6b11b1b431d40ab416c4e10e93244ab96535ead4f704c74267d816545448ae3618be2762ae148b0008952c26784fa4937ac0f3697b2d77f98d9 scummvm-2.1.1.tar.bz2
+20b20a68263c691efb7db83aa8132ec980f2732af728300a641d30c4035d4aa8fcf6efdcebb8c5b924e68fafb50e39ed1825cd64d1f81145259493e858bd50f4 fluidsynth.patch"
diff --git a/user/scummvm/fluidsynth.patch b/user/scummvm/fluidsynth.patch
new file mode 100644
index 000000000..a815cc705
--- /dev/null
+++ b/user/scummvm/fluidsynth.patch
@@ -0,0 +1,37 @@
+Backport of upstream commits:
+
+* 8593a9e
+* 68758a8
+* 8014f12
+
+--- scummvm-2.1.0/audio/softsynth/fluidsynth.cpp.old 2019-10-04 21:41:29.000000000 +0000
++++ scummvm-2.1.0/audio/softsynth/fluidsynth.cpp 2020-01-13 08:21:46.705102910 +0000
+@@ -20,10 +20,18 @@
+ *
+ */
+
+-#include "common/scummsys.h"
++#if defined(HAVE_CONFIG_H)
++#include "config.h"
++#endif
+
+ #ifdef USE_FLUIDSYNTH
+
++// Fluidsynth v2.1+ uses printf in one of it's headers,
++// include/fluidsynth/log.h around line 82 so need to include this
++// prior scummsys.h inclusion and thus forbidden.h
++#include <fluidsynth.h>
++
++#include "common/scummsys.h"
+ #include "common/config-manager.h"
+ #include "common/error.h"
+ #include "common/system.h"
+@@ -35,8 +43,6 @@
+ #include "backends/platform/ios7/ios7_common.h"
+ #endif
+
+-#include <fluidsynth.h>
+-
+ class MidiDriver_FluidSynth : public MidiDriver_Emulated {
+ private:
+ MidiChannel_MPU401 _midiChannels[16];