summaryrefslogtreecommitdiff
path: root/user/shunit2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/shunit2/APKBUILD')
-rw-r--r--user/shunit2/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/shunit2/APKBUILD b/user/shunit2/APKBUILD
new file mode 100644
index 000000000..8a110ff6d
--- /dev/null
+++ b/user/shunit2/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=shunit2
+pkgver=2.1.7
+pkgrel=0
+pkgdesc="xUnit-based unit test framework for Bourne shell scripts"
+url="https://github.com/kward/shunit2"
+arch="noarch"
+license="Apache-2.0"
+depends="/bin/sh"
+makedepends=""
+checkdepends="debianutils-which bash dash zsh"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kward/shunit2/archive/v$pkgver.tar.gz
+ dash-negative-lineno.patch"
+
+build() {
+ cd "$builddir"
+}
+
+check() {
+ cd "$builddir"
+ ./test_runner
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "doc/$pkgname.txt" "$pkgdir/usr/share/doc/$pkgname/$pkgname.rst"
+}
+
+sha512sums="35453cf2c469eb1bab2fff0624b8037a09d405c377fec0938875a6339749d5934fe246eec5691a121290ae9e4ee5cbf7768b740c5f0010a5345c4e111c50fbbd shunit2-2.1.7.tar.gz
+af2d3c65e9f3c86796b12832c403a869767b70da819f3cf6f69f0e2cf8445e85ec63db20c4b39430e35b7c2105e439abf6bbbd3fc3d880d23ee11d54339c61fd dash-negative-lineno.patch"