summaryrefslogtreecommitdiff
path: root/user/sonnet
diff options
context:
space:
mode:
Diffstat (limited to 'user/sonnet')
-rw-r--r--user/sonnet/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/user/sonnet/APKBUILD b/user/sonnet/APKBUILD
index 98c548f28..ce8297d05 100644
--- a/user/sonnet/APKBUILD
+++ b/user/sonnet/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=sonnet
-pkgver=5.41.0
+pkgver=5.43.0
pkgrel=0
pkgdesc="Framework for implementing portable spell check functionality"
url="https://www.kde.org/"
@@ -35,7 +35,8 @@ build() {
check() {
cd "$builddir"
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ # Highlighter test requires X11
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E sonnet-test_highlighter
}
package() {
@@ -47,8 +48,8 @@ aspell() {
pkgdesc="$pkdesc (aspell backend)"
install_if="$pkgname=$pkgver-$pkgrel aspell"
mkdir -p "$subpkgdir"/usr/lib/qt5/plugins/kf5/sonnet
- mv "$pkgdir"/usr/lib/qt5/plugins/kf5/sonnet/aspell.so \
- "$subpkgdir"/usr/lib/qt5/plugins/kf5/sonnet/aspell.so
+ mv "$pkgdir"/usr/lib/qt5/plugins/kf5/sonnet/sonnet_aspell.so \
+ "$subpkgdir"/usr/lib/qt5/plugins/kf5/sonnet/sonnet_aspell.so
}
-sha512sums="608b0c476f6a1bb9e598c9c3dbb58882ec80f2e3d436cf4e4657cccc2ca5abd24bf7af5f7982ff79d80eb602c92a26be498a9bd02fcb8b6ac44298b42af6648b sonnet-5.41.0.tar.xz"
+sha512sums="63ee853d5f2df8b8163253add74418e46810188d58fc4ea56ee1d6dc6cd2f25b89c40f21039840c1992b2ce84e44acce26373cedb70770ca3d806e1dc73a0aa0 sonnet-5.43.0.tar.xz"