summaryrefslogtreecommitdiff
path: root/user/spack/clingo-explicit-libatomic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/spack/clingo-explicit-libatomic.patch')
-rw-r--r--user/spack/clingo-explicit-libatomic.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/user/spack/clingo-explicit-libatomic.patch b/user/spack/clingo-explicit-libatomic.patch
new file mode 100644
index 000000000..6a1d1a0aa
--- /dev/null
+++ b/user/spack/clingo-explicit-libatomic.patch
@@ -0,0 +1,12 @@
+diff --git a/var/spack/repos/builtin/packages/clingo/package.py b/var/spack/repos/builtin/packages/clingo/package.py
+index ab5fe9a043..8a31208850 100644
+--- a/var/spack/repos/builtin/packages/clingo/package.py
++++ b/var/spack/repos/builtin/packages/clingo/package.py
+@@ -120,6 +120,7 @@ def cmake_args(self):
+ "-DCLINGO_BUILD_WITH_PYTHON=ON",
+ "-DPYCLINGO_USER_INSTALL=OFF",
+ "-DPYCLINGO_USE_INSTALL_PREFIX=ON",
++ "-DCMAKE_CXX_STANDARD_LIBRARIES=-latomic",
+ self.cmake_py_shared,
+ ]
+ if self.spec["cmake"].satisfies("@3.16.0:"):