summaryrefslogtreecommitdiff
path: root/user/speexdsp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/speexdsp/APKBUILD')
-rw-r--r--user/speexdsp/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/user/speexdsp/APKBUILD b/user/speexdsp/APKBUILD
index b6a45a1f9..9394edc7a 100644
--- a/user/speexdsp/APKBUILD
+++ b/user/speexdsp/APKBUILD
@@ -14,8 +14,12 @@ replaces="libspeex"
source="https://downloads.xiph.org/releases/speex/$pkgname-$pkgver.tar.gz"
build() {
- local _neon
- [ "$CARCH" = "aarch64" ] && _neon="--disable-neon"
+ _arch_flags=""
+
+ case $CARCH in
+ "aarch64") _arch_flags="--disable-neon"
+ esac
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,12 +28,11 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--disable-static \
- $_neon
+ $_arch_flags
make
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}