summaryrefslogtreecommitdiff
path: root/user/spice-protocol/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/spice-protocol/APKBUILD')
-rw-r--r--user/spice-protocol/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/spice-protocol/APKBUILD b/user/spice-protocol/APKBUILD
new file mode 100644
index 000000000..33dd1bdb2
--- /dev/null
+++ b/user/spice-protocol/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=spice-protocol
+pkgver=0.12.14
+pkgrel=0
+pkgdesc="Spice protocol header files"
+url="https://www.spice-space.org/"
+arch="noarch"
+license="BSD-3-Clause AND LGPL-2.1+"
+depends=""
+makedepends=""
+source="https://www.spice-space.org/download/releases/$pkgname-$pkgver.tar.bz2
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make pkgconfigdir=/usr/lib/pkgconfig DESTDIR="$pkgdir" install
+}
+
+sha512sums="4266bcbef9f641a97a2ff72f1b01380a41e51f4b1a0dbb73fdf68baf552598a62d5cf0c526adf2997a55ee5d4fe9392927c3d7f4556827bfb2933f59bfab55bb spice-protocol-0.12.14.tar.bz2"