summaryrefslogtreecommitdiff
path: root/user/syntax-highlighting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/syntax-highlighting/APKBUILD')
-rw-r--r--user/syntax-highlighting/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/syntax-highlighting/APKBUILD b/user/syntax-highlighting/APKBUILD
index 3af6526ae..9f87744f9 100644
--- a/user/syntax-highlighting/APKBUILD
+++ b/user/syntax-highlighting/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=syntax-highlighting
-pkgver=5.38.0
+pkgver=5.41.0
pkgrel=0
pkgdesc="Framework for rendering programming code with formatting"
url="https://www.kde.org/"
@@ -9,11 +9,12 @@ arch="all"
license="LGPL-2.1"
depends=""
depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev perl"
+makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev perl
+ doxygen graphviz"
checkdepends="qt5-qtxmlpatterns-dev"
install=""
-subpackages="$pkgname-dev $pkgname-lang"
-source="http://download.kde.org/stable/frameworks/5.38/syntax-highlighting-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
builddir="$srcdir/syntax-highlighting-$pkgver"
build() {
@@ -28,6 +29,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_QCH:BOOL=ON \
${CMAKE_CROSSOPTS}
make
}
@@ -42,4 +44,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1ca56399cd78e593644b3d474b4eff979762300d6d27f19a57e1e66954342ec0c6de28b4309f284d7c3c3d1f71d1ea6ca108cee0c5bb8ca1803aed5f0c69076c syntax-highlighting-5.38.0.tar.xz"
+sha512sums="86ed50766c9c0a3ef9e71421f5e7b9248ab1f28d0ecd424af57d643e613f488e572d001c55c58ab0ef501d6160b2db75dec0b325447132a5f49ff6dc6c52afea syntax-highlighting-5.41.0.tar.xz"