summaryrefslogtreecommitdiff
path: root/user/thunderbird/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/thunderbird/APKBUILD')
-rw-r--r--user/thunderbird/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/user/thunderbird/APKBUILD b/user/thunderbird/APKBUILD
index 02693efca..b115202f3 100644
--- a/user/thunderbird/APKBUILD
+++ b/user/thunderbird/APKBUILD
@@ -104,6 +104,13 @@ build() {
# gcc 6
export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
+ case "${CARCH}" in
+ armv7)
+ # 32-bit memory ceiling, #1012
+ LDFLAGS="${LDFLAGS} -Wl,--strip-debug";
+ ;;
+ esac
+
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"