summaryrefslogtreecommitdiff
path: root/user/thunderbird/rust-32bit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/thunderbird/rust-32bit.patch')
-rw-r--r--user/thunderbird/rust-32bit.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/thunderbird/rust-32bit.patch b/user/thunderbird/rust-32bit.patch
new file mode 100644
index 000000000..cff36e90b
--- /dev/null
+++ b/user/thunderbird/rust-32bit.patch
@@ -0,0 +1,32 @@
+--- firefox-91.13.0/config/makefiles/rust.mk.old 2022-08-15 13:04:32.000000000 -0500
++++ firefox-91.13.0/config/makefiles/rust.mk 2022-11-15 01:35:10.150096648 -0600
+@@ -64,19 +64,19 @@
+ # These flags are passed via `cargo rustc` and only apply to the final rustc
+ # invocation (i.e., only the top-level crate, not its dependencies).
+ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
+-ifndef DEVELOPER_OPTIONS
+-ifndef MOZ_DEBUG_RUST
++#ifndef DEVELOPER_OPTIONS
++#ifndef MOZ_DEBUG_RUST
+ # Enable link-time optimization for release builds, but not when linking
+ # gkrust_gtest. And not when doing cross-language LTO.
+-ifndef MOZ_LTO_RUST_CROSS
+-ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
+-cargo_rustc_flags += -Clto
+-endif
++#ifndef MOZ_LTO_RUST_CROSS
++#ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
++#cargo_rustc_flags += -Clto
++#endif
+ # We need -Cembed-bitcode=yes for all crates when using -Clto.
+-RUSTFLAGS += -Cembed-bitcode=yes
+-endif
+-endif
+-endif
++#RUSTFLAGS += -Cembed-bitcode=yes
++#endif
++#endif
++#endif
+
+ ifdef CARGO_INCREMENTAL
+ export CARGO_INCREMENTAL