summaryrefslogtreecommitdiff
path: root/user/tigervnc/libintl-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/tigervnc/libintl-fix.patch')
-rw-r--r--user/tigervnc/libintl-fix.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/user/tigervnc/libintl-fix.patch b/user/tigervnc/libintl-fix.patch
new file mode 100644
index 000000000..82565d276
--- /dev/null
+++ b/user/tigervnc/libintl-fix.patch
@@ -0,0 +1,26 @@
+libc gettext is never sufficient on musl
+
+--- tigervnc-1.8.0/CMakeLists.txt.old 2017-05-16 08:53:28.000000000 -0500
++++ tigervnc-1.8.0/CMakeLists.txt 2017-09-10 16:05:13.397275098 -0500
+@@ -152,9 +152,9 @@
+ set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARIES})
+ set(CMAKE_REQUIRED_FLAGS -fno-builtin-dgettext)
+ check_function_exists(dgettext LIBC_HAS_DGETTEXT)
+- if(LIBC_HAS_DGETTEXT)
+- set(GETTEXT_FOUND TRUE)
+- else()
++ #if(LIBC_HAS_DGETTEXT)
++ # set(GETTEXT_FOUND TRUE)
++ #else()
+ find_library(LIBINTL_LIBRARY NAMES intl libintl)
+ if(LIBINTL_LIBRARY)
+ check_library_exists(${LIBINTL_LIBRARY} "dgettext" "" LIBINTL_HAS_DGETTEXT)
+@@ -163,7 +163,7 @@
+ set(GETTEXT_FOUND TRUE)
+ endif()
+ endif()
+- endif()
++ #endif()
+ set(CMAKE_REQUIRED_LIBRARIES)
+ set(CMAKE_REQUIRED_FLAGS)
+ endif()