summaryrefslogtreecommitdiff
path: root/user/tinycdb
diff options
context:
space:
mode:
Diffstat (limited to 'user/tinycdb')
-rw-r--r--user/tinycdb/APKBUILD26
-rw-r--r--user/tinycdb/Makefile.patch19
2 files changed, 45 insertions, 0 deletions
diff --git a/user/tinycdb/APKBUILD b/user/tinycdb/APKBUILD
new file mode 100644
index 000000000..434e4273e
--- /dev/null
+++ b/user/tinycdb/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Alyx Wolcott <alyx@leuhta.com>
+# Maintainer: Alyx Wolcott <alyx@leuhta.com>
+pkgname=tinycdb
+pkgver=0.78
+pkgrel=0
+pkgdesc="A constant database"
+url="https://www.corpit.ru/mjt/tinycdb.html"
+arch="all"
+license="Public-Domain"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://www.corpit.ru/mjt/tinycdb/$pkgname-$pkgver.tar.gz
+ Makefile.patch"
+
+build() {
+ make prefix=/usr sysconfdir=/etc mandir=/usr/share/man localstatedir=/var
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="8930086b8e7fddcd4dbd3354c5f5ee05171df68fde1cc222b6c402430042b6e761efbad7e5fa8de18e1d36390f1526cc3e605c5086fe1c363ba1df6c03201553 tinycdb-0.78.tar.gz
+199774ee259bd6ba91ec000485c959e9632f2766203c479ffb81144d4cec39b25a1df9e9b3b676217044e2d65275ef80fbc1fd97272bce7a91fe0c1232a5dc40 Makefile.patch"
diff --git a/user/tinycdb/Makefile.patch b/user/tinycdb/Makefile.patch
new file mode 100644
index 000000000..27d32dff6
--- /dev/null
+++ b/user/tinycdb/Makefile.patch
@@ -0,0 +1,19 @@
+--- a/Makefile 2012-05-11 14:17:47.000000000 +0000
++++ b/Makefile 2020-02-25 05:56:34.969771664 +0000
+@@ -6,14 +6,14 @@
+
+ VERSION = 0.78
+
+-prefix=/usr/local
++prefix=/usr
+ exec_prefix=$(prefix)
+ bindir=$(exec_prefix)/bin
+ libdir=$(exec_prefix)/lib
+ syslibdir=$(libdir)
+ sysconfdir=/etc
+ includedir=$(prefix)/include
+-mandir=$(prefix)/man
++mandir=$(prefix)/share/man
+ NSSCDB_DIR = $(sysconfdir)
+ DESTDIR=
+