summaryrefslogtreecommitdiff
path: root/user/ttf-freefont/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/ttf-freefont/APKBUILD')
-rw-r--r--user/ttf-freefont/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/user/ttf-freefont/APKBUILD b/user/ttf-freefont/APKBUILD
new file mode 100644
index 000000000..532f064a7
--- /dev/null
+++ b/user/ttf-freefont/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer:
+pkgname=ttf-freefont
+pkgver=20120503
+pkgrel=0
+pkgdesc="High-quality TrueType fonts covering the UCS character set"
+url="http://www.nongnu.org/freefont/"
+arch="noarch"
+options="!check" # No test suite.
+license="GPL-3.0+ with exception"
+depends="encodings fontconfig mkfontdir mkfontscale"
+makedepends="font-util-dev"
+source="https://ftp.gnu.org/gnu/freefont/freefont-ttf-$pkgver.zip"
+builddir="$srcdir/freefont-$pkgver"
+
+package() {
+ cd "$builddir"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+ # Licensing exception is discussed in README in pkgver==20120503
+ install -Dm644 README "$pkgdir/usr/share/licenses/$pkgname/README"
+}
+
+sha512sums="dcd6f525e8f97631c6f84ab4cc2a31af4614dcdb9a4d434bd890baf18e0c2934032f2915384fc27fbecf60d259d792e48f52d357b07e3ed2616d3c8c3544268e freefont-ttf-20120503.zip"