summaryrefslogtreecommitdiff
path: root/user/uchardet
diff options
context:
space:
mode:
Diffstat (limited to 'user/uchardet')
-rw-r--r--user/uchardet/APKBUILD8
-rw-r--r--user/uchardet/no-debug-suffix.patch14
2 files changed, 19 insertions, 3 deletions
diff --git a/user/uchardet/APKBUILD b/user/uchardet/APKBUILD
index 153dfc63b..c25bc1baf 100644
--- a/user/uchardet/APKBUILD
+++ b/user/uchardet/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=uchardet
-pkgver=0.0.6
+pkgver=0.0.7
pkgrel=0
pkgdesc="Universal character encoding detection library"
url="https://www.freedesktop.org/wiki/Software/uchardet/"
@@ -10,7 +10,8 @@ license="MPL-1.1 OR GPL-2.0+ OR LGPL-2.1+"
depends=""
makedepends="cmake"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.freedesktop.org/software/uchardet/releases/uchardet-$pkgver.tar.xz"
+source="https://www.freedesktop.org/software/uchardet/releases/uchardet-$pkgver.tar.xz
+ no-debug-suffix.patch"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -35,4 +36,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="eceeadae060bf277e298d709856609dde32921271140dc1fb0a33c7b6e1381033fc2960d616ebbd82c92815936864d2c0743b1b5ea1b7d4a200df87df80d6de5 uchardet-0.0.6.tar.xz"
+sha512sums="ddb7b63dd09c1d9acbe620d86217e583d9aa5340780ab4010ec9faa4fd331498859d5efa7829bf8847da89325accf8f7304b51d410210178fc1ffa6658064a6f uchardet-0.0.7.tar.xz
+2e6f9d34daa6ba7dab07843368017448a17162d4d55bbc01665d00afa61a36f8b44fd6149706b806c8980632bdf33d073e0a93559d809852e18460551f330ecb no-debug-suffix.patch"
diff --git a/user/uchardet/no-debug-suffix.patch b/user/uchardet/no-debug-suffix.patch
new file mode 100644
index 000000000..f12bb565e
--- /dev/null
+++ b/user/uchardet/no-debug-suffix.patch
@@ -0,0 +1,14 @@
+diff -Nurd uchardet-0.0.7/CMakeLists.txt uchardet-0.0.7.new/CMakeLists.txt
+--- uchardet-0.0.7/CMakeLists.txt 2020-04-23 09:48:58.000000000 +0000
++++ uchardet-0.0.7.new/CMakeLists.txt 2020-06-13 08:26:38.946585352 +0000
+@@ -12,10 +12,6 @@
+ set (UCHARDET_VERSION_MINOR 0)
+ set (UCHARDET_VERSION_REVISION 7)
+
+-if (CMAKE_BUILD_TYPE MATCHES Debug)
+- set (version_suffix .debug)
+-endif (CMAKE_BUILD_TYPE MATCHES Debug)
+-
+ set (
+ UCHARDET_VERSION
+ ${UCHARDET_VERSION_MAJOR}.${UCHARDET_VERSION_MINOR}.${UCHARDET_VERSION_REVISION}${version_suffix}