summaryrefslogtreecommitdiff
path: root/user/unifont
diff options
context:
space:
mode:
Diffstat (limited to 'user/unifont')
-rw-r--r--user/unifont/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/unifont/APKBUILD b/user/unifont/APKBUILD
new file mode 100644
index 000000000..a3da61bf0
--- /dev/null
+++ b/user/unifont/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Breno Leitao <breno.leitao@gmail.com>
+# Maintainer:
+pkgname=unifont
+pkgver=11.0.01
+pkgrel=0
+pkgdesc="GNU font package with all Unicode 11 characters"
+url="http://unifoundry.com/unifont.html"
+arch="all"
+options="!check" # No way to test fonts.
+license="GPL-2.0+ WITH Font-exception-2.0 AND GPL-2.0+ AND GFDL-1.3+"
+depends="bdftopcf perl-gd"
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://unifoundry.com/pub/unifont/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ # Build fails with parallel make jobs.
+ make DESTDIR="$pkgdir" -j1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b6668dfc0eb95a0ca313bd8a3e330c06b928d536d1c00f837398ab210beb0a8f251e85cdca8787116eb92e7990c2157c81b7353be2112396a468ea252a93de1d unifont-11.0.01.tar.gz"