summaryrefslogtreecommitdiff
path: root/user/utf8proc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/utf8proc/APKBUILD')
-rw-r--r--user/utf8proc/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/user/utf8proc/APKBUILD b/user/utf8proc/APKBUILD
index a878a0abd..4b8d6ac3a 100644
--- a/user/utf8proc/APKBUILD
+++ b/user/utf8proc/APKBUILD
@@ -4,13 +4,14 @@ pkgname=utf8proc
pkgver=2.4.0
pkgrel=0
pkgdesc="C library for processing UTF-8 data"
-url=" "
+url="http://juliastrings.github.io/utf8proc"
arch="all"
license="MIT AND Unicode-DFS-2016"
depends=""
makedepends=""
subpackages="$pkgname-dev"
-source="utf8proc-$pkgver.tar.gz::https://github.com/JuliaStrings/utf8proc/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/JuliaStrings/utf8proc/archive/v$pkgver.tar.gz
+ https://dev.sick.bike/dist/$pkgname-testdata-$pkgver.tar.gz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -27,12 +28,12 @@ build() {
}
check() {
- cd "$builddir"/build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ make check
}
package() {
make DESTDIR="$pkgdir" -C build install
}
-sha512sums="2bbd056b488cd30faca26618389d8af84edc39ade9b705e147b676bf39eee65b40239d01c32c46dfc2a289d79e869ed1bb3c347365603dcaab2f69e34427441a utf8proc-2.4.0.tar.gz"
+sha512sums="2bbd056b488cd30faca26618389d8af84edc39ade9b705e147b676bf39eee65b40239d01c32c46dfc2a289d79e869ed1bb3c347365603dcaab2f69e34427441a utf8proc-2.4.0.tar.gz
+1d41e9138ef2f41a0bf79e0613695c516da87f79f53032476d585f91040f9c6231f4e67944b43ffa16d7d96cfd3841c15d7f09a7178f45ac6b6b3585e97050fc utf8proc-testdata-2.4.0.tar.gz"