summaryrefslogtreecommitdiff
path: root/user/vorbis-tools
diff options
context:
space:
mode:
Diffstat (limited to 'user/vorbis-tools')
-rw-r--r--user/vorbis-tools/APKBUILD43
-rw-r--r--user/vorbis-tools/CVE-2014-9638-and-9639.patch87
-rw-r--r--user/vorbis-tools/CVE-2014-9640.patch51
-rw-r--r--user/vorbis-tools/CVE-2015-6749.patch46
4 files changed, 227 insertions, 0 deletions
diff --git a/user/vorbis-tools/APKBUILD b/user/vorbis-tools/APKBUILD
new file mode 100644
index 000000000..eaf358c07
--- /dev/null
+++ b/user/vorbis-tools/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Nathan <ndowens@artixlinux.org>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=vorbis-tools
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Tools for Ogg-Vorbis"
+url="https://www.xiph.org/vorbis"
+arch="all"
+license="GPL-2.0+"
+depends=""
+makedepends="curl-dev flac-dev libvorbis-dev
+ libao-dev speex-dev"
+subpackages="$pkgname-lang $pkgname-doc"
+source="http://downloads.xiph.org/releases/vorbis/vorbis-tools-$pkgver.tar.gz
+ CVE-2014-9638-and-9639.patch
+ CVE-2014-9640.patch
+ CVE-2015-6749.patch
+ "
+
+prepare() {
+ update_config_guess
+ default_prepare
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --enable-vcut
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d2473f2e8e6726b5a5083f567797ae42bbb7fa3f26aec3f7b83e641e028c64726299f71a9d75258595a53cf29c18acb84841bcbc39509258d2c8df859e4e3b99 vorbis-tools-1.4.0.tar.gz
+fbe006c1de1b5d03dd84a3213d840468658129bc83f1fad9bcb738d53fd0f76b5f2ebc17b95c456d8b73456b313282bad5e08703649ba8b506371e6c8b466557 CVE-2014-9638-and-9639.patch
+9cb9ca5a7cc648e75a4b0027f29f59edd81156578864c46cc2ff773435175a35ea2f31da480e983d05c23d1285d59f0f8a0ec97dd57ba8c11ee5786b619fbaa2 CVE-2014-9640.patch
+bf49f572e023678a12d764e459d518f067499a07bd9fe6c037e00730349e066d96174a52043f61dff44fd788b336018c68ae4d26ebe279dc6bf0a07852048ff0 CVE-2015-6749.patch"
diff --git a/user/vorbis-tools/CVE-2014-9638-and-9639.patch b/user/vorbis-tools/CVE-2014-9638-and-9639.patch
new file mode 100644
index 000000000..2585b47be
--- /dev/null
+++ b/user/vorbis-tools/CVE-2014-9638-and-9639.patch
@@ -0,0 +1,87 @@
+From 3bbabc06c4b35c84f6747ed850213161aca568c7 Mon Sep 17 00:00:00 2001
+From: Petter Reinholdtsen <pere@debian.org>
+Date: Tue, 22 Sep 2015 15:14:06 +0200
+Subject: [PATCH] oggenc: validate count of channels in the header
+ (CVE-2014-9638 & CVE-2014-9639)
+
+Author: Kamil Dudka <kdudka@redhat.com>
+Origin: http://lists.xiph.org/pipermail/vorbis-dev/2015-February/020423.html
+Bug: https://trac.xiph.org/ticket/2136
+Bug: https://trac.xiph.org/ticket/2137
+Bug-Debian: https://bugs.debian.org/776086
+Forwarded: not-needed
+Reviewed-By: Petter Reinholdtsen <pere@hungry.com>
+Last-Update: 2015-09-22
+---
+ oggenc/audio.c | 18 ++++++++++++++++--
+ 1 file changed, 16 insertions(+), 2 deletions(-)
+
+diff --git a/oggenc/audio.c b/oggenc/audio.c
+index 4921fb9..535a704 100644
+--- a/oggenc/audio.c
++++ b/oggenc/audio.c
+@@ -13,6 +13,7 @@
+ #include <config.h>
+ #endif
+
++#include <limits.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -251,6 +252,7 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ aiff_fmt format;
+ aifffile *aiff = malloc(sizeof(aifffile));
+ int i;
++ long channels;
+
+ if(buf[11]=='C')
+ aifc=1;
+@@ -277,11 +279,16 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ return 0;
+ }
+
+- format.channels = READ_U16_BE(buffer);
++ format.channels = channels = READ_U16_BE(buffer);
+ format.totalframes = READ_U32_BE(buffer+2);
+ format.samplesize = READ_U16_BE(buffer+6);
+ format.rate = (int)read_IEEE80(buffer+8);
+
++ if(channels <= 0L || SHRT_MAX < channels)
++ {
++ fprintf(stderr, _("Warning: Unsupported count of channels in AIFF header\n"));
++ return 0;
++ }
+ aiff->bigendian = 1;
+
+ if(aifc)
+@@ -416,6 +423,7 @@ int wav_open(FILE *in, oe_enc_opt *opt, unsigned char *oldbuf, int buflen)
+ wav_fmt format;
+ wavfile *wav = malloc(sizeof(wavfile));
+ int i;
++ long channels;
+
+ /* Ok. At this point, we know we have a WAV file. Now we have to detect
+ * whether we support the subtype, and we have to find the actual data
+@@ -453,12 +461,18 @@ int wav_open(FILE *in, oe_enc_opt *opt, unsigned char *oldbuf, int buflen)
+ }
+
+ format.format = READ_U16_LE(buf);
+- format.channels = READ_U16_LE(buf+2);
++ format.channels = channels = READ_U16_LE(buf+2);
+ format.samplerate = READ_U32_LE(buf+4);
+ format.bytespersec = READ_U32_LE(buf+8);
+ format.align = READ_U16_LE(buf+12);
+ format.samplesize = READ_U16_LE(buf+14);
+
++ if(channels <= 0L || SHRT_MAX < channels)
++ {
++ fprintf(stderr, _("Warning: Unsupported count of channels in WAV header\n"));
++ return 0;
++ }
++
+ if(format.format == -2) /* WAVE_FORMAT_EXTENSIBLE */
+ {
+ if(len<40)
+--
+GitLab
+
diff --git a/user/vorbis-tools/CVE-2014-9640.patch b/user/vorbis-tools/CVE-2014-9640.patch
new file mode 100644
index 000000000..f21994b58
--- /dev/null
+++ b/user/vorbis-tools/CVE-2014-9640.patch
@@ -0,0 +1,51 @@
+From 514116d7bea89dad9f1deb7617b2277b5e9115cd Mon Sep 17 00:00:00 2001
+From: Gregory Maxwell <greg@xiph.org>
+Date: Wed, 16 Apr 2014 23:55:10 +0000
+Subject: [PATCH] oggenc: fix crash on raw file close, reported by Hanno in
+ issue #2009. pointer to a non-static struct was escaping its scope. Also fix
+ a C99-ism.
+
+svn path=/trunk/vorbis-tools/; revision=19117
+---
+ oggenc/oggenc.c | 4 ++--
+ oggenc/skeleton.h | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/oggenc/oggenc.c b/oggenc/oggenc.c
+index 4a120f3..e7de0bb 100644
+--- a/oggenc/oggenc.c
++++ b/oggenc/oggenc.c
+@@ -97,6 +97,8 @@ int main(int argc, char **argv)
+ .3,-1,
+ 0,0,0.f,
+ 0, 0, 0, 0, 0};
++ input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
++ N_("RAW file reader")};
+
+ int i;
+
+@@ -239,8 +241,6 @@ int main(int argc, char **argv)
+
+ if(opt.rawmode)
+ {
+- input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
+- N_("RAW file reader")};
+
+ enc_opts.rate=opt.raw_samplerate;
+ enc_opts.channels=opt.raw_channels;
+diff --git a/oggenc/skeleton.h b/oggenc/skeleton.h
+index cf87dc2..168b8b6 100644
+--- a/oggenc/skeleton.h
++++ b/oggenc/skeleton.h
+@@ -41,7 +41,7 @@ typedef struct {
+ ogg_int64_t granule_rate_d; /* granule rate denominator */
+ ogg_int64_t start_granule; /* start granule value */
+ ogg_uint32_t preroll; /* preroll */
+- unsigned char granule_shift; // a 8-bit field /* 1 byte value holding the granule shift */
++ unsigned char granule_shift; /* 1 byte value holding the granule shift */
+ char *message_header_fields; /* holds all the message header fields */
+ /* current total size of the message header fields, for realloc purpose, initially zero */
+ ogg_uint32_t current_header_size;
+--
+GitLab
+
diff --git a/user/vorbis-tools/CVE-2015-6749.patch b/user/vorbis-tools/CVE-2015-6749.patch
new file mode 100644
index 000000000..b83f70cc2
--- /dev/null
+++ b/user/vorbis-tools/CVE-2015-6749.patch
@@ -0,0 +1,46 @@
+From c1059cd1e5c9278fe73a044d0e0792cac75f44b3 Mon Sep 17 00:00:00 2001
+From: Petter Reinholdtsen <pere@debian.org>
+Date: Tue, 22 Sep 2015 14:56:58 +0200
+Subject: [PATCH] oggenc: Fix large alloca on bad AIFF input (CVE-2015-6749).
+
+Author: Mark Harris <mark.hsj@gmail.com>
+Origin: https://trac.xiph.org/attachment/ticket/2212/0001-oggenc-Fix-large-alloca-on-bad-AIFF-input.patch
+Bug-Debian: https://bugs.debian.org/797461
+Forwarded: https://trac.xiph.org/ticket/2212
+Reviewed-By: Petter Reinholdtsen <pere@hungry.com>
+Last-Update: 2015-09-22
+---
+ oggenc/audio.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/oggenc/audio.c b/oggenc/audio.c
+index 477da8c..4921fb9 100644
+--- a/oggenc/audio.c
++++ b/oggenc/audio.c
+@@ -245,8 +245,8 @@ static int aiff_permute_matrix[6][6] =
+ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ {
+ int aifc; /* AIFC or AIFF? */
+- unsigned int len;
+- unsigned char *buffer;
++ unsigned int len, readlen;
++ unsigned char buffer[22];
+ unsigned char buf2[8];
+ aiff_fmt format;
+ aifffile *aiff = malloc(sizeof(aifffile));
+@@ -269,9 +269,9 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ return 0; /* Weird common chunk */
+ }
+
+- buffer = alloca(len);
+-
+- if(fread(buffer,1,len,in) < len)
++ readlen = len < sizeof(buffer) ? len : sizeof(buffer);
++ if(fread(buffer,1,readlen,in) < readlen ||
++ (len > readlen && !seek_forward(in, len-readlen)))
+ {
+ fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n"));
+ return 0;
+--
+GitLab
+