summaryrefslogtreecommitdiff
path: root/user/weechat/fix-unsigned-char.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/weechat/fix-unsigned-char.patch')
-rw-r--r--user/weechat/fix-unsigned-char.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/user/weechat/fix-unsigned-char.patch b/user/weechat/fix-unsigned-char.patch
deleted file mode 100644
index d4acd1986..000000000
--- a/user/weechat/fix-unsigned-char.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-This patch is backported from the upcoming 2.4 release. It corrects
-highlighting behavior for plugins such as urlserver.py.
-
-See-Also: https://github.com/weechat/weechat/issues/1277
-Patch-Author: Sébastien Helleu <flashcode@flashtux.org>
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0ae69ea0f..1d7738af5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -27,8 +27,8 @@ project(weechat C)
- set(CMAKE_VERBOSE_MAKEFILE OFF)
- set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
- set(CMAKE_SKIP_RPATH ON)
--set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror-implicit-function-declaration")
--set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror-implicit-function-declaration")
-+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsigned-char -Wall -Wextra -Werror-implicit-function-declaration")
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fsigned-char -Wall -Wextra -Werror-implicit-function-declaration")
-
- # version
- execute_process(COMMAND ${CMAKE_SOURCE_DIR}/version.sh devel-major OUTPUT_VARIABLE VERSION_MAJOR)
-diff --git a/configure.ac b/configure.ac
-index d267ca10f..a0bf00078 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1330,7 +1330,7 @@ AC_DEFINE_UNQUOTED(WEECHAT_SHAREDIR, "$WEECHAT_SHAREDIR")
- weechat_libdir=${libdir}/weechat
- AC_SUBST(weechat_libdir)
-
--COMMON_CFLAGS="-Wall -Wextra -Werror-implicit-function-declaration"
-+COMMON_CFLAGS="-fsigned-char -Wall -Wextra -Werror-implicit-function-declaration"
- AC_MSG_CHECKING([whether we have GNU assembler])
- GAS=`as --version < /dev/null 2>/dev/null | grep GNU`
- if test "$GAS"; then
---
-2.19.1
-