summaryrefslogtreecommitdiff
path: root/user/weechat/libintl-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/weechat/libintl-fix.patch')
-rw-r--r--user/weechat/libintl-fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/user/weechat/libintl-fix.patch b/user/weechat/libintl-fix.patch
new file mode 100644
index 000000000..a67cb37b6
--- /dev/null
+++ b/user/weechat/libintl-fix.patch
@@ -0,0 +1,12 @@
+libc gettext is never sufficient on musl
+
+--- weechat-1.9/CMakeLists.txt.old 2017-06-25 03:20:52.000000000 -0500
++++ weechat-1.9/CMakeLists.txt 2017-09-13 02:30:43.577284569 -0500
+@@ -162,6 +162,7 @@
+ find_package(Gettext)
+ if(GETTEXT_FOUND)
+ add_definitions(-DENABLE_NLS)
++ list(APPEND EXTRA_LIBS intl)
+ endif()
+ endif()
+