summaryrefslogtreecommitdiff
path: root/user/which/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/which/APKBUILD')
-rw-r--r--user/which/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/which/APKBUILD b/user/which/APKBUILD
new file mode 100644
index 000000000..42e7e3b10
--- /dev/null
+++ b/user/which/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=which
+pkgver=2.21
+pkgrel=1
+pkgdesc="A utility to show the full path of commands"
+url="http://savannah.gnu.org/projects/which"
+arch="all"
+license="GPL-2.0+ AND LGPL-2.0+ AND GPL-3.0+"
+makedepends=""
+subpackages="$pkgname-doc"
+source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d2f04a5c5291f2d7d1226982da7cf999d36cfe24d3f7bda145508efcfb359511251d3c68b860c0ddcedd66b15a0587b648a35ab6d1f173707565305c506dfc61 which-2.21.tar.gz"