summaryrefslogtreecommitdiff
path: root/user/wimlib
diff options
context:
space:
mode:
Diffstat (limited to 'user/wimlib')
-rw-r--r--user/wimlib/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/wimlib/APKBUILD b/user/wimlib/APKBUILD
new file mode 100644
index 000000000..a8268910a
--- /dev/null
+++ b/user/wimlib/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: CyberLeo <cyberleo@cyberleo.net>
+# Maintainer: CyberLeo <cyberleo@cyberleo.net>
+pkgname=wimlib
+pkgver=1.13.1
+pkgrel=0
+pkgdesc="Windows Imaging (WIM) archive manipulation library and tools"
+url="https://wimlib.net/"
+arch="all"
+license="(GPL-2.0 OR LGPL-2.1) AND CC0"
+depends=""
+makedepends="libxml2-dev fuse-dev ntfs-3g ntfs-3g-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-libs"
+source="https://wimlib.net/downloads/wimlib-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+check() {
+ PATH="/usr/sbin:${PATH}" make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="a874eafa979e715adf06398371380f06ae42370392473b2eb8aca969b2019664b187f3f2bfa74819bc1d85db4977a08e915c69efc67e77e933c82e6bbcda0243 wimlib-1.13.1.tar.gz"