summaryrefslogtreecommitdiff
path: root/user/wireguard-module/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/wireguard-module/APKBUILD')
-rw-r--r--user/wireguard-module/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/user/wireguard-module/APKBUILD b/user/wireguard-module/APKBUILD
index 614beff16..4088a7817 100644
--- a/user/wireguard-module/APKBUILD
+++ b/user/wireguard-module/APKBUILD
@@ -1,36 +1,34 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer: Luis Ressel <aranea@aixah.de>
-# KEEP THIS IN SYNC with the other wireguard-module packages.
-_kflavour=""
_kver="5.4.5-mc0"
-pkgver=0.0.20191226
+pkgver=0.0.20200121
pkgrel=0
-_pkgname="wireguard-module$_kflavour"
+_pkgname="wireguard-module"
pkgname="$_pkgname-$_kver"
_pkgreal="wireguard-linux-compat"
pkgdesc="Kernel module for the WireGuard VPN, built for easy-kernel"
url="https://www.wireguard.com/"
arch="all"
-options="!check !dbg !strip" # no test suite
+options="!check !dbg !strip" # No test suite.
license="GPL-2.0-only"
+depends="easy-kernel-modules-$_kver"
+makedepends="easy-kernel-src-$_kver"
provides="$_pkgname=$pkgver"
-depends="easy-kernel$_kflavour-modules-$_kver"
-makedepends="easy-kernel$_kflavour-src-$_kver"
subpackages="wireguard-patch:_patch:noarch"
source="https://git.zx2c4.com/$_pkgreal/snapshot/$_pkgreal-$pkgver.tar.xz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- make -C src LDFLAGS="" KERNELDIR="/usr/src/linux-$_kver$_kflavour" module
+ make -C src LDFLAGS="" KERNELDIR="/usr/src/linux-$_kver" module
}
package() {
if [ -f $HOME/kernel_key.pem ]; then
- /usr/src/linux-$_kver$_kflavour/scripts/sign-file sha512 \
+ /usr/src/linux-$_kver/scripts/sign-file sha512 \
$HOME/kernel_key.pem $HOME/kernel_key.pem \
"$builddir"/src/wireguard.ko
fi
- make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver$_kflavour" INSTALL_MOD_PATH="$pkgdir" module-install
+ make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver" INSTALL_MOD_PATH="$pkgdir" module-install
}
_patch() {
@@ -41,4 +39,4 @@ _patch() {
"$builddir"/kernel-tree-scripts/create-patch.sh > "$subpkgdir/usr/share/wireguard/wireguard-$pkgver.patch"
}
-sha512sums="7eba183128555ca5fd8b171179fe8ec7b9a67c618ad000bc9c5475ff74097e0e2c220a1f1dd82393fbde6dbbba5c1114bfd725e733a5f4acfbb23248538f6afb wireguard-linux-compat-0.0.20191226.tar.xz"
+sha512sums="fde9ef09032ad2e2ce69814d42cc0abb3b353d5aa95debd39122b3eb25324c8e707dd9f298f8ee276575d932b1f1bd559b3430da6b8c0a5057911937ed85c726 wireguard-linux-compat-0.0.20200121.tar.xz"