summaryrefslogtreecommitdiff
path: root/user/xcb-util
diff options
context:
space:
mode:
Diffstat (limited to 'user/xcb-util')
-rw-r--r--user/xcb-util/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/user/xcb-util/APKBUILD b/user/xcb-util/APKBUILD
index 90b9053bf..cb0f0046e 100644
--- a/user/xcb-util/APKBUILD
+++ b/user/xcb-util/APKBUILD
@@ -6,14 +6,14 @@ pkgdesc="Utility libraries for X C-language Binding"
url="https://xcb.freedesktop.org/"
arch="all"
license="X11"
+depends=""
depends_dev="libxcb-dev util-macros"
-makedepends="$depends_dev m4 gperf"
checkdepends="check-dev"
+makedepends="$depends_dev m4 gperf"
subpackages="$pkgname-dev"
source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,12 +23,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}