summaryrefslogtreecommitdiff
path: root/user/xfce-desktop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/xfce-desktop/APKBUILD')
-rw-r--r--user/xfce-desktop/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/xfce-desktop/APKBUILD b/user/xfce-desktop/APKBUILD
new file mode 100644
index 000000000..7044a7dd7
--- /dev/null
+++ b/user/xfce-desktop/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce-desktop
+pkgver=4.13
+pkgrel=0
+arch="noarch"
+pkgdesc="Complete XFCE desktop environment"
+url="https://xfce.org"
+license="NCSA"
+options="!check" # meta package, no tests needed.
+depends="xfburn xfce4-power-manager xfce4-settings xfce4-volumed-pulse
+ xfdesktop xfce4-appfinder xfce4-panel xfce4-screenshooter
+ xfce4-taskmanager xfconf xfce4-dict xfce4-panel-profiles
+ xfce4-session xfdashboard xfmpc xfwm4 xfce4-terminal
+ xfce4-notifyd"
+source="org.adelie-linux.about-xfce.desktop"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$srcdir"
+}
+
+package() {
+ cd "$srcdir"
+ install -D -m644 "$srcdir"/org.adelie-linux.about-xfce.desktop \
+ "$pkgdir"/usr/share/applications/org.adelie-linux.about-xfce.desktop
+}
+sha512sums="362793e478e3fb0c6d7dca1f52f582a641ff4582ad0c0d6d1cbe28f1255fc6cd7918ea6b24a5d905a59275f67c44703bf8c78580642c4e0147b539842a6f372f org.adelie-linux.about-xfce.desktop"