summaryrefslogtreecommitdiff
path: root/user/xfce4-indicator-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'user/xfce4-indicator-plugin')
-rw-r--r--user/xfce4-indicator-plugin/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/xfce4-indicator-plugin/APKBUILD b/user/xfce4-indicator-plugin/APKBUILD
new file mode 100644
index 000000000..db59691a5
--- /dev/null
+++ b/user/xfce4-indicator-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-indicator-plugin
+pkgver=2.3.4
+pkgrel=0
+pkgdesc="Application information plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev libindicator-dev ido-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-indicator-plugin/2.3/xfce4-indicator-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b1fd065c8221ae91d95b540411317cd67bb9b26d46c7cfe85ec90d7ccdcd11e7b8832008c8b6fb5c257e0b1a08360f00ad9da5520108024cc36c63d865ffdca6 xfce4-indicator-plugin-2.3.4.tar.bz2"