summaryrefslogtreecommitdiff
path: root/user/xfce4-notes-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/xfce4-notes-plugin/APKBUILD')
-rw-r--r--user/xfce4-notes-plugin/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/xfce4-notes-plugin/APKBUILD b/user/xfce4-notes-plugin/APKBUILD
new file mode 100644
index 000000000..25c2dec03
--- /dev/null
+++ b/user/xfce4-notes-plugin/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=xfce4-notes-plugin
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="XFCE panel plugin for sticky notes"
+url="https://www.xfce.org"
+arch="all"
+license="GPL-2.0+"
+depends=""
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+source="https://archive.xfce.org/src/panel-plugins/xfce4-notes-plugin/1.9/xfce4-notes-plugin-$pkgver.tar.bz2"
+
+build() {
+ LIBS="-lintl" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="32ee410fa9d4dff4f73a844ac53024c39a884b48cee32faf14c1ed75200f912bd4e51a1fe3305deea9ec98a617b63a65e271437b09cb9b664498746a8095f4a1 xfce4-notes-plugin-1.9.0.tar.bz2"