summaryrefslogtreecommitdiff
path: root/user/xfce4-whiskermenu-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/xfce4-whiskermenu-plugin/APKBUILD')
-rw-r--r--user/xfce4-whiskermenu-plugin/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/user/xfce4-whiskermenu-plugin/APKBUILD b/user/xfce4-whiskermenu-plugin/APKBUILD
index cf44747f1..c09d74cc3 100644
--- a/user/xfce4-whiskermenu-plugin/APKBUILD
+++ b/user/xfce4-whiskermenu-plugin/APKBUILD
@@ -1,5 +1,5 @@
-# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=xfce4-whiskermenu-plugin
pkgver=2.3.4
_pkgmaj=${pkgver%.*}
@@ -7,9 +7,10 @@ pkgrel=0
pkgdesc="Whisker menu plugin for the XFCE panel"
url="https://xfce.org"
arch="all"
-options="!check" # no tests
+options="!check" # No test suite.
license="GPL-2.0+"
-makedepends="gtk+3.0-dev exo-dev garcon-dev xfce4-panel-dev"
+depends=""
+makedepends="cmake gtk+3.0-dev exo-dev garcon-dev xfce4-panel-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="https://archive.xfce.org/src/panel-plugins/xfce4-whiskermenu-plugin/$_pkgmaj/xfce4-whiskermenu-plugin-$pkgver.tar.bz2"
@@ -24,7 +25,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}