summaryrefslogtreecommitdiff
path: root/user/xorg-drivers/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/xorg-drivers/APKBUILD')
-rw-r--r--user/xorg-drivers/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/xorg-drivers/APKBUILD b/user/xorg-drivers/APKBUILD
new file mode 100644
index 000000000..c6442655d
--- /dev/null
+++ b/user/xorg-drivers/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xorg-drivers
+pkgver=1.0
+pkgrel=0
+pkgdesc="Drivers for X.Org systems"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+options="!check !dbg" # Metapacakge
+subpackages=""
+depends="xf86-input-evdev xf86-input-joystick xf86-input-keyboard
+ xf86-input-libinput xf86-input-mouse xf86-input-synaptics
+ xf86-input-void xf86-input-wacom
+
+ xf86-video-ast xf86-video-ati xf86-video-cirrus xf86-video-dummy
+ xf86-video-fbdev xf86-video-freedreno xf86-video-mach64 xf86-video-mga
+ xf86-video-nouveau xf86-video-openchrome xf86-video-qxl xf86-video-r128
+ xf86-video-tdfx"
+case $CTARGET_ARCH in
+ pmmx)
+ depends="$depends xf86-video-geode xf86-video-intel" ;;
+ x86_64)
+ depends="$depends xf86-video-intel" ;;
+esac
+source=""
+
+package() {
+ mkdir -p $pkgdir
+}