summaryrefslogtreecommitdiff
path: root/user/xsetmode
diff options
context:
space:
mode:
Diffstat (limited to 'user/xsetmode')
-rw-r--r--user/xsetmode/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/user/xsetmode/APKBUILD b/user/xsetmode/APKBUILD
new file mode 100644
index 000000000..37615c3f3
--- /dev/null
+++ b/user/xsetmode/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xsetmode
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Set the mode on an XInput device"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="libx11-dev libxi-dev"
+subpackages="$pkgname-doc"
+source="https://www.x.org/releases/individual/app/xsetmode-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="a3c1c5e85a0cec35a7db10a57eece07691c0bec79b93987ec4417ebf71544ddffbb4832f78ef524bfcd149beb9852295a2de6a2ccec481cd6eea5633e090abfb xsetmode-1.0.0.tar.bz2"